Account management issues
Incident Report for Kraken.io
Resolved
A fix has been deployed, account management is functional again. Sorry for the inconvenience.
Posted Oct 12, 2020 - 18:34 CEST
Identified
We have identified an issue affecting account management, and are implementing a fix for it. To avoid damage to the account data we have temporarily disabled account changes.
Posted Oct 12, 2020 - 18:04 CEST
This incident affected: Kraken.io Homepage.