Recurly transit outtage
Incident Report for Kraken.io
Resolved
All issues with our billing provider have been resolved. Please contact support@kraken.io with any questions.
Posted over 2 years ago. May 10, 2016 - 19:51 CEST
Investigating
Our payment provider is currently facing issues, you may have problems accessing your Kraken.io account at this time. We'll keep you posted.
Posted over 2 years ago. May 10, 2016 - 14:43 CEST